JEvents for Joomla 2.5 Available Now

Joomla 2.5 changes the way that some view class files are named which means that JEvents 2.0.x is not compatible with Joomla 2.5.

JEvents 2.1.10 addresses this issue and is now available for to all users.  This was possible thanks to the ongoing support of members of the JEvents club without whom developing such a large and complex application as JEvents would be impossible.

Its best to upgrade JEvents to version 2.1.10+ before upgrading Joomla to version 2.5 so that you will not have any downtime during the Joomla upgrade process.  You will also need to upgrade any club layouts you have installed.   It is recommended that you test all your components, modules and plugins with version 2.5 of Joomla before you upgrade a live site - there are a number of major components that have not yet released in Joomla 2.5 compatible versions.

Login Form