JEvents 3.1 (Free Access)

Custom Fields - XML not loaded & Layout Questions  Topic is solved

Forum for JEvents 3.1 for Joomla 3.x and 2.5.
Forum rules
When requesting support please follow these steps:

1. Update all JEvents add on's first, via the Joomla! Updater
2. Copy and Paste the JEvents Support Information from the JEvents Control Panel.
3. If you get a 500 error OR white page, enable Maximum Error Reporting in Joomla! Global Config and visit the page again, this should give you a more detailed error and help us provide a prompt response.

Postby sonnenlanze » Wed Feb 13, 2013 4:57 pm

Hey everybody,

I updated to Jevents 3 and have also replaced all of the addons, plugins, modules etc.
Code: Select all
Joomla : 2.5.8
component_com_jevents : 3.0.7
component_com_jevlocations : 3.0.1
module_mod_jevents_cal : 3.0.7
module_mod_jevents_filter : 3.0.7
module_mod_jevents_latest : 3.0.7
module_mod_jevents_legend : 3.0.7
module_mod_jevents_switchview : 3.0.7
layout_manifest : 3.0.0
layout_map : 3.0.1
plugin_editors_jce : 2.3.1
plugin_finder_jevents : 3.0.7
plugin_jevents_jevcustomfields : 3.0.3
plugin_jevents_jevfiles : 3.0
plugin_jevents_jevlocations : 3.0.1
plugin_search_eventsearch : 3.0.7
plugin_search_jevlocsearch : 3.0.1


I've had some Custom Field which I wanted to see again - so I've read the (new) Documentation: https://www.jevents.net/product-docs/21 ... sage-notes and did everything as stated (open & configure the Plugin, save it, make a custom fields.xml, configure it again in the Plugin)

The "all fields" XML File has <field> Tags instead of <param> Tags, like in the fieldsamle-files.
Every time I try <param> I get a "XML File not loaded" Error, when I try to access my Event List Layout.
Every time I try <field> I don't get the error, but the fields are not listed in the available field list on the right. It only says "Custom Field Summary" but nothing is displayed even if I add that...

This is my Plugin Config:
CUstom Plugin Settings.png
CUstom Plugin Settings.png (9.61 KiB) Viewed 1270 times


So - what do I need to do to get my custom fields into the Layout?

And the second Issue:
Template Problems.png
Template Problems.png (67.44 KiB) Viewed 1270 times

The Event Detail Parts with the time Info is broken...

Can you help me with this?
Thanks and kind regards,
Vanessa
sonnenlanze
 
Posts: 229
Joined: Wed Dec 15, 2010 3:18 pm

Postby Tonyp » Wed Feb 13, 2013 7:31 pm

Hello Vanessa,

params was for Joomla! 1.5 only, 2.5 uses Field.

Have you got an event detail layout default edited and published? Can you check and add your custom fields to it. Are you trying to use event detail or list row to get the fields to appear.

Regards
Tony
---------------------------------------
Feel free to PM me if you would like Custom Installs or Joomla! related work for a competitive quote.

User avatar
Tonyp
Team Staff
 
Posts: 23785
Joined: Tue Oct 12, 2010 9:12 pm
Location: Isle of Man

Postby sonnenlanze » Thu Feb 14, 2013 10:15 am

Hi Tony,

I cannot add the custom fields from the fields.xml into my layout (red circle on the right). They just don't appear in the list.
layout.png
layout.png (78.51 KiB) Viewed 1265 times

I've had custom field before the update - so my old custom fields are still in the existing layout (here: Event List, red circle on the left).

I really don't understand why the xml is not interpreted. :/
Thanks for you help,
Vanessa
sonnenlanze
 
Posts: 229
Joined: Wed Dec 15, 2010 3:18 pm

Postby Geraint » Thu Feb 14, 2013 2:06 pm

Please check the access level for the fields to make sure it is at least 1=public.

If you give us the URL of the XML file we can take a look to see if we can spot any obvious errors.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42811
Joined: Fri Feb 15, 2008 6:14 pm

Postby sonnenlanze » Thu Feb 14, 2013 2:34 pm

URL and htaccess-Info per PM on it's way!
sonnenlanze
 
Posts: 229
Joined: Wed Dec 15, 2010 3:18 pm

Postby Geraint » Fri Feb 15, 2013 6:51 am

I didn't get these - did you send them to me or Tony?
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42811
Joined: Fri Feb 15, 2008 6:14 pm

Postby sonnenlanze » Fri Feb 15, 2013 7:29 am

Hm... Both... I'll try again
sonnenlanze
 
Posts: 229
Joined: Wed Dec 15, 2010 3:18 pm

Postby Geraint » Fri Feb 15, 2013 8:00 am

Still not there - you are clicking PM under my picture? Are you remembering to click submit and then checking that it worked - if your message is too long there may be an error message/waring displayed
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42811
Joined: Fri Feb 15, 2008 6:14 pm

Postby sonnenlanze » Fri Feb 15, 2013 9:24 am

I know - was on my phone earlier... Re-sent the message a minute ago.
sonnenlanze
 
Posts: 229
Joined: Wed Dec 15, 2010 3:18 pm

Postby Geraint » Fri Feb 15, 2013 4:57 pm

I don't see the custom fields input when editing an event.

Do you have a template override for the event editing page? Do you see the custom fields when editing an event?
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42811
Joined: Fri Feb 15, 2008 6:14 pm

Next

Return to JEvents 3.1 (Free Access)

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there are 2 users online :: 2 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: Google [Bot], Yahoo [Bot]