Jevents 2.x (Free Access)

Missing date - March 31st 2013  Topic is solved

Discuss JEvents 2.x for Joomla 1.5-2.5 here - club members can use the special club forum for faster response times.
Forum rules
When requesting support please follow these steps:

1. Update all JEvents add on's first, via the Joomla! Updater
2. Copy and Paste the JEvents Support Information from the JEvents Control Panel.
3. If you get a 500 error OR white page, enable Maximum Error Reporting in Joomla! Global Config and visit the page again, this should give you a more detailed error and help us provide a prompt response.

Postby Geraint » Sat Feb 02, 2013 12:33 pm

The bug was in 3.0.6 - I just uploaded 3.0.7 which fixes the issue (subject to clearing your web browser cache or doing a forced reload of the page to reload the javascript file).

The problem was that in the date test (following adding support for date formats other than YYYY-MM-DD) we were setting a date day before setting a date month which was causing the problem since we are now in February. This new code was written and tested during December and January when this problem would not have arisen.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42837
Joined: Fri Feb 15, 2008 6:14 pm

Postby Roelands » Sat Feb 02, 2013 3:20 pm

Hi, I'm sorry...not solved after update to 3.0.7 ; I also tried to set the date to j-m-d ; that also does not help. Also a change to (config-component) date configuration US or French-English does not help (was ond default language). Sorry :-(
Roelands
 
Posts: 6
Joined: Sat Feb 02, 2013 10:29 am

Postby MaryKate » Sat Feb 02, 2013 3:45 pm

Geraint wrote:Please try version 3.0.7 which has resolved these issues.


Thanks for the quick response. If I upgrade to the new version, will this delete my events that I've created? Dumb question, I know, but afraid to try it without knowing.

btw...LOVE jevents!!! Thanks for providing such a great module!
MaryKate
 
Posts: 3
Joined: Fri Feb 01, 2013 5:44 pm

Postby Geraint » Sat Feb 02, 2013 3:48 pm

@Roelands:
Did you clear your browser cache or do a forced reload of the event edit page. this is necessary to get a fresh copy of /administrator/components/com_jevents/assets/js/editical.js from the server.

This file should have this code at lines 51-52
Code: Select all
         // set month to January  to ensure we can set days to 31 first!!!
         date.set('month', 0);


@MaryKate
Upgrading will not affect your existing data - just install on top of the old version. An up to date backup is always a good idea though.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42837
Joined: Fri Feb 15, 2008 6:14 pm

Postby Roelands » Sat Feb 02, 2013 4:24 pm

Hi Geraint. Thanks for the support. I have two PC's; on one (Desktop) it's ok now. The other one (Laptop) has been restarted but still has this issue. I guess it has to do with some settings. Will have a look further Tomorrow; here it's time to get some food ;-). Again thansk !
Roelands
 
Posts: 6
Joined: Sat Feb 02, 2013 10:29 am

Postby MaryKate » Sun Feb 03, 2013 1:02 pm

Thanks, Geraint! Uploaded 3.0.7 and works like a charm! I did have to clear my expired cache first tho. Don't understand much about caches yet, but clearing just the cache didn't help. After I cleared the expire cache it started working. Thanks for your help!
MaryKate
 
Posts: 3
Joined: Fri Feb 01, 2013 5:44 pm

Previous

Return to Jevents 2.x (Free Access)

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there are 0 users online :: 0 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: No registered users