JEvents 3.1 (Free Access)

Broken Joomla Update when installing JEvents

Forum for JEvents 3.1 for Joomla 3.x and 2.5.
Forum rules
When requesting support please follow these steps:

1. Update all JEvents add on's first, via the Joomla! Updater
2. Copy and Paste the JEvents Support Information from the JEvents Control Panel.
3. If you get a 500 error OR white page, enable Maximum Error Reporting in Joomla! Global Config and visit the page again, this should give you a more detailed error and help us provide a prompt response.

Postby LennartMart » Thu Jan 24, 2013 9:35 pm

Hi, I'm currently testing the new Joomla! I want to migrate my old 1.5 website, so I exported my articles to joomla 2.5 and made an upgrade to 3. When I try to install my favorite extension, I notice that the Joomla Update function fails: 500 php_network_getaddresses: getaddrinfo failed: Name or service not known .
This error dissapears when uninstalling JEvents. And it appears again when I reinstall JEvents. So...

Using Joomla! 3.0.2 en JEvents 3.0.3
LennartMart
 
Posts: 9
Joined: Thu Jan 24, 2013 9:32 pm

Postby Tonyp » Fri Jan 25, 2013 12:11 am

Hello,

Doing a quick google makes this look like a potential Server issue. see:

http://joomlacode.org/gf/project/amoryr ... d_id=16703

Albeit an old topic.

But, it's possible when we use getaddrinfo it fails.

Can you contact your hosting company?

Regards
Tony
---------------------------------------
Feel free to PM me if you would like Custom Installs or Joomla! related work for a competitive quote.

User avatar
Tonyp
Team Staff
 
Posts: 23633
Joined: Tue Oct 12, 2010 9:12 pm
Location: Isle of Man

Postby LennartMart » Fri Jan 25, 2013 8:06 am

I can contact my hosting company, but it's really strange that when I install JEvents, it breaks the Joomla! Update function. Same issue with Gantry when I look it up with Google.

Also, the component is unusable when running Joomla in development mode. When I try to open the component, it is stuck in an endless loop.
LennartMart
 
Posts: 9
Joined: Thu Jan 24, 2013 9:32 pm

Postby Tonyp » Fri Jan 25, 2013 10:39 pm

Hello,

You should not be in Development Mode unless you are a developer?

This shows all sorts of future deprecations and strict standards. Maximum is the Maximum you will want to use.

Regards
Tony
---------------------------------------
Feel free to PM me if you would like Custom Installs or Joomla! related work for a competitive quote.

User avatar
Tonyp
Team Staff
 
Posts: 23633
Joined: Tue Oct 12, 2010 9:12 pm
Location: Isle of Man

Postby LennartMart » Fri Jan 25, 2013 11:23 pm

Yeah, I know, I just tried to get more information aput this error, without result...
LennartMart
 
Posts: 9
Joined: Thu Jan 24, 2013 9:32 pm

Postby LennartMart » Mon Jan 28, 2013 9:36 am

Well, I think I found the problem.
Allow_url_fopen is disabled on my shared hosting. The hosting company says it is for security reasons.

Is this really important in JEvents ? Or can I disable that function somewhere in the code?

(I can't turn on allow_url_fopen with htaccess)
LennartMart
 
Posts: 9
Joined: Thu Jan 24, 2013 9:32 pm

Postby Tonyp » Mon Jan 28, 2013 10:06 am

Hello,

In the JEvents Config can you disable project news?

Regards
Tony
---------------------------------------
Feel free to PM me if you would like Custom Installs or Joomla! related work for a competitive quote.

User avatar
Tonyp
Team Staff
 
Posts: 23633
Joined: Tue Oct 12, 2010 9:12 pm
Location: Isle of Man

Postby LennartMart » Mon Jan 28, 2013 11:25 am

Doesn't work, still problem with Joomla! Updater and Extension updater.

It isn't a bug, it's a problem with my hosting. I hope I can solve it with him ...
LennartMart
 
Posts: 9
Joined: Thu Jan 24, 2013 9:32 pm

Postby joomla3user » Mon Jan 28, 2013 10:14 pm

I have been getting the error also:

500 php_network_getaddresses: getaddrinfo failed: Name or service not known

So I went ahead and uninstalled JEvents 3.0.4 and now the Joomla! Update feature works.

Just disabling JEvents still caused the problem to remain.
joomla3user
 
Posts: 1
Joined: Mon Jan 28, 2013 7:26 pm

Postby LennartMart » Tue Jan 29, 2013 7:55 pm

Well, allow_url_fopen is now enabled, but it doesn't work.

I'm glad I'm not the only one with this problem. I'm still wondering why JEvents breaks Joomla! Updater...
LennartMart
 
Posts: 9
Joined: Thu Jan 24, 2013 9:32 pm

Next

Return to JEvents 3.1 (Free Access)

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there is 1 user online :: 1 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: Google [Bot]