Jevents 2.x (Free Access)

404 Cat. not found  Topic is solved

Discuss JEvents 2.x for Joomla 1.5-2.5 here - club members can use the special club forum for faster response times.
Forum rules
When requesting support please follow these steps:

1. Update all JEvents add on's first, via the Joomla! Updater
2. Copy and Paste the JEvents Support Information from the JEvents Control Panel.
3. If you get a 500 error OR white page, enable Maximum Error Reporting in Joomla! Global Config and visit the page again, this should give you a more detailed error and help us provide a prompt response.

Postby drak » Thu Jan 03, 2013 12:00 am

Getting a 404-Category not found error on Jevents menu I created. It’s a monthly menu but get the same for multiple types. I can get calendar to display in a mod but when clicked gets the same 404 error. I’ve found several threads about this, and it seems it's a SEF issue. Everything works with SEF turned off in Joomla config but when on, I get the '404 cat. not found' page. I’m on a fresh install of Joomla 2.5.8 and Jevents (ver 2.2.8) and setting it up a new site. My hosting is Godaddy.

My htaccess does have rewrite turned on, and I’ve tried changing the Jevents SEF configuration option to off but doesn’t help. Also I have no menu item restrictions. Currently running php 5.3 on a linux hosted server.

I also tried changing my htaccess file to .htaccess to see if there's any effect but no change. I’ve used Jevents on 2 other sites so far with no issues and it’s far superior to other options out there, but I’m a little frustrated because I’ve not been able to troubleshoot this issue effectively so far. Any suggestions would be greatly appreciated.
drak
 
Posts: 12
Joined: Wed Jan 02, 2013 11:47 pm

Postby Tonyp » Thu Jan 03, 2013 8:15 am

Hello,

What does the URL look like? do you use any SEF plugins apart from the standard Joomla! one?

Regards
Tony
---------------------------------------
Feel free to PM me if you would like Custom Installs or Joomla! related work for a competitive quote.

User avatar
Tonyp
Team Staff
 
Posts: 23841
Joined: Tue Oct 12, 2010 9:12 pm
Location: Isle of Man

Postby drak » Thu Jan 03, 2013 12:51 pm

URL is: …/index.php/events-calendar/month_calendar/2013/01/-

I use no SEF extensions, and the only extensions I’ve installed so far are JCE editor, JCE MediaBox and ALFContact. If I take away from the URL everything after the ‘events-calendar’ then the calendar comes up but still can’t click on a date without getting the 404 page.
drak
 
Posts: 12
Joined: Wed Jan 02, 2013 11:47 pm

Postby Geraint » Thu Jan 03, 2013 2:30 pm

Try disabling the new SEF Urls in the Jevents config (SEF) tab - its possible that your server software doesn't like the underscore in the month_calendar part of the URL.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42850
Joined: Fri Feb 15, 2008 6:14 pm

Postby drak » Thu Jan 03, 2013 3:34 pm

Geraint wrote:Try disabling the new SEF Urls in the Jevents config (SEF) tab - its possible that your server software doesn't like the underscore in the month_calendar part of the URL.


As I mentioned in my initial post, I tried that.
drak
 
Posts: 12
Joined: Wed Jan 02, 2013 11:47 pm

Postby Geraint » Thu Jan 03, 2013 3:48 pm

The 404 category error is normally caused by the joomla SEF system redirecting the URL to the default com_content output.

What does the non-SEF version of the URL look like?

If you rename .htaccess back to htaccess.txt is the problem resolved?
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42850
Joined: Fri Feb 15, 2008 6:14 pm

Postby drak » Thu Jan 03, 2013 3:52 pm

I did rename the htaccess file back to original name after I found renaming didn't help.

.../index.php?option=com_jevents&view=month&layout=calendar&Itemid=120
drak
 
Posts: 12
Joined: Wed Jan 02, 2013 11:47 pm

Postby Geraint » Fri Jan 04, 2013 8:20 am

I assume that there is no .../ at the start of the URL - that is just shorthand for the domain ??

This problem is arising outside of JEvents - your site isn't even getting to JEvents (com_jevents) its going to com_content for some reason. Please disable any non-core Joomla system plugins you may have installed. Also try the URL without the &Itemid=120 at the end
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42850
Joined: Fri Feb 15, 2008 6:14 pm

Postby drak » Sat Jan 05, 2013 3:27 am

The URL I put above works fine, it's what I have with the Joomla SEF options off. I don't want to keep that off though, so I'm still looking for a solution.
drak
 
Posts: 12
Joined: Wed Jan 02, 2013 11:47 pm

Postby Tonyp » Sat Jan 05, 2013 7:01 pm

With SEF Enabled, please try enabled JEvents SEF in it's configuration options.
---------------------------------------
Feel free to PM me if you would like Custom Installs or Joomla! related work for a competitive quote.

User avatar
Tonyp
Team Staff
 
Posts: 23841
Joined: Tue Oct 12, 2010 9:12 pm
Location: Isle of Man

Next

Return to Jevents 2.x (Free Access)

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there are 0 users online :: 0 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: No registered users