Jevents 2.x (Free Access)

New events not showing up from frontend and no pop up calend  Topic is solved

Discuss JEvents 2.x for Joomla 1.5-2.5 here - club members can use the special club forum for faster response times.
Forum rules
When requesting support please follow these steps:

1. Update all JEvents add on's first, via the Joomla! Updater
2. Copy and Paste the JEvents Support Information from the JEvents Control Panel.
3. If you get a 500 error OR white page, enable Maximum Error Reporting in Joomla! Global Config and visit the page again, this should give you a more detailed error and help us provide a prompt response.

Postby chriso0258 » Mon May 07, 2012 1:56 pm

I created a user for front end calendar update. The Joomla permissions I gave them are: Registered, author, editor, publisher. I gave this user permission for the first 7 options in JEvents (from "enabled" up to and including "delete all".

I then logged the user in from the front end. Clicked the "add an event" and filled in the fields. Whether I click "Save" or "Apply", the form data disappears and there is no event listed in "Manage Events" listings.

What have I not configured correctly?

One other note, in the "Event Editing" configuration there is a setting, "Should date entry always force popup calendar?". Whether I have this set to yes or no, I can get no pop-up calendar (which I want).
chriso0258
 
Posts: 12
Joined: Tue May 01, 2012 4:45 pm

Postby Tonyp » Mon May 07, 2012 6:10 pm

Hello,

If you view the events in the backend are they there?

You have probably set it to be reviewed before being published? check the JEvents Config settings.
---------------------------------------
Feel free to PM me if you would like Custom Installs or Joomla! related work for a competitive quote.

User avatar
Tonyp
Team Staff
 
Posts: 23633
Joined: Tue Oct 12, 2010 9:12 pm
Location: Isle of Man

Postby chriso0258 » Mon May 07, 2012 7:00 pm

I did think of that but I'm afraid the events do not show up in the backend (I did ensure the settings were for "all events" etc). Where is this review before publish option?

Also, I noticed in the backend that under the filter category of "Event Creator" the other user does not show up, only the super user. I don't know if that's because this user has not created an event in the backend or if it should appear regardless. This may be a related problem.

The popup calendar is also not appearing regardless of setting the option to force its use in the configuration.
chriso0258
 
Posts: 12
Joined: Tue May 01, 2012 4:45 pm

Postby Tonyp » Mon May 07, 2012 9:36 pm

It sounds like a possible permission issue.

Can you enable Authorised User Mode, and add the users manually? this is the easiest solution.

Otherwise check the groups permissions for rights etc.
---------------------------------------
Feel free to PM me if you would like Custom Installs or Joomla! related work for a competitive quote.

User avatar
Tonyp
Team Staff
 
Posts: 23633
Joined: Tue Oct 12, 2010 9:12 pm
Location: Isle of Man

Postby chriso0258 » Tue May 08, 2012 2:27 am

I enabled authorized user as suggested. I deleted the old user and created a new user within Joomla admin. I am still having the same issue. Since this is only a test site, I would be happy to pm you a user/password to access the site and look around if you think that might help.
chriso0258
 
Posts: 12
Joined: Tue May 01, 2012 4:45 pm

Postby Tonyp » Tue May 08, 2012 7:39 am

Hello,

Can you


Forum rules
When requesting support, please copy and paste the 'Version information for Support Forum' from the JEvents Control Panel into your post. If you cannot see this, please enable JEvents project news within it's configuration.


We only provide that level of support to Club Members.

Regards
Tony
---------------------------------------
Feel free to PM me if you would like Custom Installs or Joomla! related work for a competitive quote.

User avatar
Tonyp
Team Staff
 
Posts: 23633
Joined: Tue Oct 12, 2010 9:12 pm
Location: Isle of Man

Postby chriso0258 » Wed May 09, 2012 5:02 pm

No problem. I can appreciate the policy.

Code: Select all
Joomla : 2.5.4
component_com_jevents : 2.1.18
module_mod_jevents_latest : 2.1.5
plugin_editors_jce : 2.0.21


I tried deleting the events and category and recreating but when I log in as the calendar admin (front end), again, there is no popup calendar to set the date and when I click either apply or save, the data disappears. I would think one command would maintain the current screen and data and the other would save and close. I have also tried giving the calendar admin superuser permission to eliminate an ACL issue but have the same problem.
chriso0258
 
Posts: 12
Joined: Tue May 01, 2012 4:45 pm

Postby Geraint » Wed May 09, 2012 5:48 pm

It sounds as though there could be a javascript problem. You probably have a non-Joomla javascript library jQuery being loaded which is clashing with the Joomla mootools library.

Check for javascript errors
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42781
Joined: Fri Feb 15, 2008 6:14 pm

Postby chrisyork » Mon Oct 15, 2012 2:18 pm

Hi,
Sorry to jump in on this thread, but I have part of this problem - the calendar pop up is not working on the front end.

Thanks for the pointer as to why it might not be working and it seems you are right. I had a look for javascript conflicts and it appears that joostrap cookie control module is a problem...

Now, given that we need something about cookie use on the site to comply with EU law (and its the only Joomla module I've found to do this easily), can you suggest a way round this to keep both things running?

I realise that this might not be considered your problem, because it is a conflict between two 3rd party items, but any help with pointing a way forward would be much appreciated. I will ask at Joostrap as well, just in case its something that they can change easily... And I'll post back here if I get a result

Many thanks
Chris
BTW here is my version information:
Code: Select all
Joomla : 2.5.4
component_com_jevents : 2.2.7
module_mod_jevents_latest : 2.2.4
module_mod_jevents_legend : 2.1.13
plugin_editors_jce : 2.2.4
plugin_system_jcemediabox : 1.1.3 (not enabled)
chrisyork
 
Posts: 14
Joined: Mon Feb 02, 2009 10:15 am

Postby Tonyp » Mon Oct 15, 2012 2:44 pm

Hello,

Can you confirm this is from the Component it's self and not a menu item?

Secondly have you tried using Google Chrome and its built in developer tools(F12) and look at its console then refresh the page.

Copy any errors and post them here.

Regards
Tony
---------------------------------------
Feel free to PM me if you would like Custom Installs or Joomla! related work for a competitive quote.

User avatar
Tonyp
Team Staff
 
Posts: 23633
Joined: Tue Oct 12, 2010 9:12 pm
Location: Isle of Man

Next

Return to Jevents 2.x (Free Access)

cron
  • Who is online
  • View new posts
  • View unanswered posts
  • In total there is 1 user online :: 1 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: Baidu [Spider]