JEvents 1.5 (No longer actively supported)

SOLVED - Bug in JEvents Calendar module

JEvents 2.0 was launched over 2 years ago and the latest stable version is version 2.2 which will run on Joomla 1.5 and Joomla 2.5. JEvents 1.5 is therefore no longer actively supported - you should upgrade to JEvents 2.2+ as soon as possible.
Forum rules
Please include as much detail in any test or bug reports for JEvents 1.5 as possible.

First of all, check if you are running the latest available version of Joomla! and JEvents. Posts for issues, where both systems are not updated, will be ignored.

We need the following at least:

* PHP version (e.g. 5.2.5). Note: Support for PHP4 is discontinued.
* Joomla! version
* JEvents version
* Web Server software (Apache or IIS with version number if possible)
* Server Operating system (e.g. Linux, Windows, Solaris, Darwin ...)
* Database version
* memory_limit from your phpinfo
* Web browser and version

Please enable error reporting and include any error messages in your posting. You do this via the Joomla Configuration - set "error reporting" to "maximum" on the Server tab.

Finally, please describe the steps required to recreate the problem and also please enable error reporting and give us any error messages generated.

Postby markchicobaby » Sat Jul 04, 2009 7:04 am

Hi when you click on the right or left arrows on the JEvents calendar module (the mini calendar) the large monthly view of the calendar changes, but the module's mini calendar itself doesn't change. It stays stuck on the current month. I'm using the ext theme.

How to correct this?

Thanks
Mark
---
Latest versions of everything, just a new install (the bug also happens on the demo site of JEvents).
New install 1.5.1
PHP 5.2.5
Firefox 3.0.12
Joomla 1.5.12
markchicobaby
 
Posts: 8
Joined: Sat Jul 04, 2009 6:33 am

Postby Geraint » Sat Jul 04, 2009 8:40 am

This isn't a bug - it is mirroring the behaviour of the old defunct ExtCalendar on which the Ext layout is based.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42850
Joined: Fri Feb 15, 2008 6:14 pm

Postby markchicobaby » Wed Jul 08, 2009 5:38 am

Geraint wrote:This isn't a bug - it is mirroring the behaviour of the old defunct ExtCalendar on which the Ext layout is based.

It's not intuitive and it looks bad.

How do I fix it? Any tips?

Thanks
M
markchicobaby
 
Posts: 8
Joined: Sat Jul 04, 2009 6:33 am

Postby Geraint » Wed Jul 08, 2009 6:43 am

Look at the code of the other modules as a starting point.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42850
Joined: Fri Feb 15, 2008 6:14 pm

Postby markchicobaby » Wed Jul 08, 2009 8:46 am

Geraint wrote:Look at the code of the other modules as a starting point.

Well yes that much is obvious :D . What I meant was do you have any tips on what modifications to do.

I don't yet understand fully how the calendar is architected so I'm flying blind at the moment.

M
markchicobaby
 
Posts: 8
Joined: Sat Jul 04, 2009 6:33 am

Postby Geraint » Wed Jul 08, 2009 10:19 am

You'll see in the default layout in particular that there is a jsnavigation function being called instead of a html link. This calls the ajax type updater which replaces the mini calendar content.

It actually uses a hidden Iframe instead of true ajax so you could make the iframe visible to see the result of this navigation call.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42850
Joined: Fri Feb 15, 2008 6:14 pm

Postby dascott » Fri Mar 30, 2012 5:43 pm

I'm experiencing the same "non-functional" prev/next arrows in the JE 2.1.11 mini calendar module in Joomla 2.5.1 with the TR_Clarion commercial theme. No JS errors, thus no function call clashes and no theme/plugin JS collisions, etc.

Here are all the JS's used by my site ( [url]comeandreason.com[/url] ), minus a default Joomla email address encoder JS...

Code: Select all
  <script src="/media/system/js/mootools-core.js" type="text/javascript"></script>
  <script src="/media/system/js/core.js" type="text/javascript"></script>
  <script src="/media/system/js/mootools-more.js" type="text/javascript"></script>
  <script src="http://comeandreason.com//plugins/system/jatypo/jatypo/assets/script.js" type="text/javascript"></script>
  <script src="/media/system/js/modal.js" type="text/javascript"></script>
  <script src="http://comeandreason.com/plugins/system/flowplayerreloaded/flowplayer_r/javascripts/flowplayer-3.2.6.min.js" type="text/javascript"></script>
  <script src="http://comeandreason.com/plugins/system/flowplayerreloaded/flowplayer_r/swfplugins/flowplayer.ipad-3.2.2.min.js" type="text/javascript"></script>
  <script src="/plugins/system/jat3/jat3/base-themes/default/js/core.js" type="text/javascript"></script>
  <script src="/plugins/system/jat3/jat3/base-themes/default/js/menu/mega.js" type="text/javascript"></script>
  <script src="/media/system/js/caption.js" type="text/javascript"></script>
  <script src="http://ajax.googleapis.com/ajax/libs/jquery/1.5.1/jquery.min.js" type="text/javascript"></script>
  <script src="/modules/mod_ariimageslider/mod_ariimageslider/js/jquery.noconflict.js" type="text/javascript"></script>
  <script src="/modules/mod_ariimageslider/mod_ariimageslider/js/jquery.nivo.slider.js" type="text/javascript"></script>
  <script type="text/javascript">
window.addEvent('domready', function(){
              SqueezeBox.initialize();
              SqueezeBox.assign($$('a[href^=#fprrpopup]'),{parse: 'rel'});
      });
window.addEvent('load', function() {
            new JCaption('img.caption');
         });
jQuery(window).load(function() { var $ = window.jQueryNivoSlider || jQuery; $("#ais_91").nivoSlider({"slices":10,"boxCols":10,"animSpeed":1000,"pauseTime":9000,"directionNav":false,"directionNavHide":false,"controlNav":false,"keyboardNav":false,"disableClick":true}); });
  </script>
<script type="text/javascript">
function googleTranslateElementInit() {
     new google.translate.TranslateElement({
    pageLanguage: 'en',
   includedLanguages:'af,mt,sw,ht,sq,be,bg,hr,cs,et,el,hu,lv,lt,mk,pl,ro,ru,sr,sk,sl,uk,ca,da,nl,en,fi,fr,gl,de,is,ga,it,no,pt,es,sv,cy,yi,eu,ar,zh-CN,zh-TW,tl,iw,hi,id,ja,ko,ms,fa,th,tr,vi,ur,hy,az,ka,',
   multilanguagePage: true
 },  'google_translate_element');
}</script>
<script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script>
<script type="text/javascript">
                var megamenu = new jaMegaMenuMoo ('ja-megamenu', {
                    'bgopacity': 0,
                    'delayHide': 600,
                    'slide'    : 1,
                    'fading'   : 0,
                    'direction': 'down',
                    'action'   : 'mouseover',
                    'tips'     : false,
                    'duration' : 300,
                    'hidestyle': 'fastwhenshow'
                });
            </script>
<script type="text/javascript">
    window.addEvent('load', function (){ equalHeight ('#ja-topsl .ja-box') });
</script>



Viewing the source HTML, when I copy/paste the URL in onmousedown=callNavigation() directly into the browser (appended after the domain name, obviously), the result is nothing... a totally blank "page." No html. Nothing.

I modified the tmpl/default/calendar.php js at line 423 (all lines are double spaced in Programmer's Notepad) to make the appended iframe visible (myiframe.style.display = "visible";)

The iframe is properly appended when any of the arrows in the mini cal are clicked, but, per the same behavior as above, the iframe is blank/empty. Here is the callNavigation() generated iframe appended to the body...

Code: Select all
<iframe src="index.php?option=com_jevents&amp;task=modcal.ajax&amp;day=1&amp;month=03&amp;year=2012&amp;modid=92&amp;tmpl=component" style="" id="calnav" name="calnav"></iframe>


Again, the URL produces ZERO OUTPUT inside the frame, thus no change in the module mini cal!!! (its mystical to me how the contents of an iframe can change contents of the mini cal)

Do you see anything glaring, out of the ordinary? Backend access can be granted if needed.

Thanks!
dascott
 
Posts: 9
Joined: Tue Aug 30, 2011 7:22 pm

Postby carcam » Sat Mar 31, 2012 8:30 am

Plugins that add automatic translation of sites usually makes weird things. Can you please try disabling it and checking again?

By the way you are using a pretty insecure Joomla! version (actually two important secure fixes has happened since 2.5.1) and your JEvents version is neither up to date, you may try to update everything and try again too ;)
¿Sabías que tenemos soporte en español para los miembros del Club de JEvents? ¡ÚNETE AHORA!
User avatar
carcam
Team Staff
 
Posts: 7114
Joined: Wed Aug 06, 2008 7:50 pm
Location: Almería

Postby Geraint » Sat Mar 31, 2012 9:38 am

dascott wrote:Again, the URL produces ZERO OUTPUT inside the frame, thus no change in the module mini cal!!! (its mystical to me how the contents of an iframe can change contents of the mini cal)

the output in the iframe is javascript which updates the parent page.

Try right clicking in the iframe in firefox/chrome and view the frame source.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42850
Joined: Fri Feb 15, 2008 6:14 pm

Postby dascott » Sat Mar 31, 2012 4:43 pm

I opened up the iframe in a new tab. It's URL is

http://comeandreason.com/index.php?option=com_jevents&task=modcal.ajax&day=1&month=04&year=2012&modid=92&tmpl=component

The Source View is blank/empty.

Thanks for the tip re. versions. I just updated the site from 1.5.x not even a month ago and went live a few days ago. Had no idea it and jevents were that quickly outdated.

I just updated all jevent files (don't have legend installed)... no effect. Then I disabled the Google Translate module. No change either.

Will upping to Joomla 2.5.3 really make a difference?
dascott
 
Posts: 9
Joined: Tue Aug 30, 2011 7:22 pm

Next

Return to JEvents 1.5 (No longer actively supported)

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there is 1 user online :: 1 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: Bing [Bot]