JEvents 3.1 (Free Access)

Something is not working  Topic is solved

Forum for JEvents 3.1 for Joomla 3.x and 2.5.
Forum rules
When requesting support please follow these steps:

1. Update all JEvents add on's first, via the Joomla! Updater
2. Copy and Paste the JEvents Support Information from the JEvents Control Panel.
3. If you get a 500 error OR white page, enable Maximum Error Reporting in Joomla! Global Config and visit the page again, this should give you a more detailed error and help us provide a prompt response.

Postby RedGarfield » Thu Nov 01, 2012 9:56 am

I am building a new site (joomla 3.0) and i'am using JEvents 3.0.

On the left site I have a list of events. When i click on one, i get to see the details. When I click on a other, nothing change.

Site: www.classic-rally.info

Peter
RedGarfield
 
Posts: 6
Joined: Thu Nov 01, 2012 9:51 am

Postby Geraint » Thu Nov 01, 2012 10:31 am

That is VERY STRANGE - can you enable Joomla debug mode on the System tab of the main Joomla config so we can see what database queries are being used.

Also what cache settings are you using?
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42799
Joined: Fri Feb 15, 2008 6:14 pm

Postby RedGarfield » Thu Nov 01, 2012 10:46 am

The debug mode is on.

My site-cache settings are:
Cache: On - progressive caching
Cache handler: file
Cache time:15

The cache settings for JEvents:
Use Joomla cache: Yes
RedGarfield
 
Posts: 6
Joined: Thu Nov 01, 2012 9:51 am

Postby Geraint » Thu Nov 01, 2012 11:17 am

The problem is with the Joomla caching - there are no JEvents queries being called when you visit http://www.classic-rally.info/index.php ... 73f8240ccc at all.

Try siwtching off the cache in Jevents and then in Joomla.

I'll do some investigating since it looks like a Joomla 3.0 bug.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42799
Joined: Fri Feb 15, 2008 6:14 pm

Postby RedGarfield » Thu Nov 01, 2012 11:24 am

I switched of the cache in JEvents and after that in Joomle.

It seems that that was the problem, now it is working great.
RedGarfield
 
Posts: 6
Joined: Thu Nov 01, 2012 9:51 am

Postby Geraint » Thu Nov 01, 2012 11:30 am

I just recreated your site and there is definitely a Joomla bug - if you enable maximum error reporting (server tab of Joomla config) you get an error message

Notice: Undefined property: JSite::$registeredurlparams in /black/var/www/clients/joomla3production/libraries/joomla/cache/cache.php on line 658

A search on google (https://www.google.co.uk/search?client= ... 94&bih=759) suggests its been reported but there is no solution that I see so far other than disabling joomla caching for the time being.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42799
Joined: Fri Feb 15, 2008 6:14 pm

Postby RedGarfield » Thu Nov 01, 2012 11:35 am

Thanks for everything.

Now i can go further with building my site.
RedGarfield
 
Posts: 6
Joined: Thu Nov 01, 2012 9:51 am

Postby RedGarfield » Thu Nov 01, 2012 11:50 am

When i turn of the debug mode, the problems are back again.....
RedGarfield
 
Posts: 6
Joined: Thu Nov 01, 2012 9:51 am

Postby Geraint » Thu Nov 01, 2012 12:55 pm

Did you leave caching off?
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42799
Joined: Fri Feb 15, 2008 6:14 pm

Postby RedGarfield » Thu Nov 01, 2012 12:59 pm

Yes, I did.

Now i installed Joomla 2.5.7 because I had more problems.
I will wait untill Joomla 3.0 is stable.

Thanx for everything.
RedGarfield
 
Posts: 6
Joined: Thu Nov 01, 2012 9:51 am

Next

Return to JEvents 3.1 (Free Access)

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there are 0 users online :: 0 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: No registered users