Jevents 2.x (Free Access)

Extensive use of cache...  Topic is solved

Discuss JEvents 2.x for Joomla 1.5-2.5 here - club members can use the special club forum for faster response times.
Forum rules
When requesting support please follow these steps:

1. Update all JEvents add on's first, via the Joomla! Updater
2. Copy and Paste the JEvents Support Information from the JEvents Control Panel.
3. If you get a 500 error OR white page, enable Maximum Error Reporting in Joomla! Global Config and visit the page again, this should give you a more detailed error and help us provide a prompt response.

Postby ttsog » Mon Oct 08, 2012 11:41 am

Hi all!

I have enabled the Global Cache in my Joomla 2.5.4 site and since then I have noticed that Jevents is filling up the cache folder extensively! I have done everything to redirect crawlers to specific dates but with no success.

My version of is JEvents 2.1. I have set the parameter "Set meta-tag to stop robots crawling" to "YES" and I have set "Menu item for robots (Type must be Crawler)" to a menu item with a date range of just one day (practically it should not return any event). I have set "Block 'show all' in list views" to "YES"

I have experimented with both Progressive and Conservative cache.

Any help would be appreciated since I have to clean my cache (Cache group com_jevents) twice or three times a day!

Takis Tsogkarakis
ttsog
 
Posts: 4
Joined: Fri Jun 15, 2012 12:02 pm

Postby Geraint » Mon Oct 08, 2012 1:08 pm

You could disable the caching within the JEvents config and use the Joomla page caching as an alternative. What cache expiry window do you have?

Did you set a reasonably tight limit on the years in the calendar e.g. +/- 2years?

There are some badly behaved crawlers out there - did you block access to these completely as described in the JEvents performance article http://www.jevents.net/jevents-15-topme ... vents-site - using these tools on Jevents.net the cache doesn't ever grow too large


Finally if you give me
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42781
Joined: Fri Feb 15, 2008 6:14 pm

Postby ttsog » Mon Oct 08, 2012 2:19 pm

Thanks for the reply!

I have the same problem with both parameters set in JEvents Config -> Component: Use Joomla Cache: Yes, No. You suggest turn this parameter to YES and use System Cache Plugin? (currently disabled)

The time limit everywhere (Component, Main menu item etc is 0d - +12m (1 year) except from the dummy menu item (Search engine crawler) which is set to just one day.

Despite that the caching on Server Configuration is set for only 30 minutes, many files are created every minute (!!!!) 100+ KB each. Shouldn't they be removed from the directory ../cache/com_jevents after half an hour?

How can I identify these badly behaved crawlers so that to block their access?

Thanks again for your quick response

Takis Tsogkarakis
ttsog
 
Posts: 4
Joined: Fri Jun 15, 2012 12:02 pm

Postby Geraint » Tue Oct 09, 2012 9:03 am

Look at the access logs to find bad crawlers - there is a list of the ones I have found in the article I linked above + instructions on how to block them. Make sure you configure your latest events and calendar module to create javascript links too.

Also can you give me the URL so I can look at your site to make sure the settings are being respected. Its possible that a plugin or your template is overriding the nofollow,noindex settings from JEvents.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42781
Joined: Fri Feb 15, 2008 6:14 pm

Postby ttsog » Tue Oct 09, 2012 10:59 am

I have finally blocked some bad crawlers (bogou, 80legs etc) but the cache folder keeps growing up rapidly. the pages generated by the calendar have the metatag (noindex, nofollow) as you can see by yourself: http://www.advendure.com/index.php/cale ... stevents/- (this is the main calendar page. Click on any event, View page source and you will see the "noindex, nofollow" metatag.

I have installed the Latest JEvents Module with caching disabled. I don't use the calendar module, only the component.

You can see the settings of the component on the attached images

If I disable the cache globally from Joomla configuration (which is the most desired in my case as we are a news site with forum, comments, hits in articles etc), JEvents consumes a huge amount of bandwith and causes the site to reach its limit. If I disable the cache inside Joomla, is there a way to cache only the JEvents component?

Thanks in advance!

Image

Image
ttsog
 
Posts: 4
Joined: Fri Jun 15, 2012 12:02 pm

Postby Geraint » Tue Oct 09, 2012 11:05 am

A few thoughts:

1. You don't have many events so disable the navigation icons on all your JEvents pages. This way many of the 'empty' Jevents links will not be found by crawlers.

2. Tell Google, Bing etc. to update the calendar pages less often - I think using a sitemap addon you can specify different update times for different menu items.

3. If the cache still increases quickly for JEvents you need to find who is visiting the links. It would not surprise me if you have Russian or Chinese search engines crawling your site which is probably not much benefit for a Greek/english site.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42781
Joined: Fri Feb 15, 2008 6:14 pm

Postby ttsog » Fri Oct 12, 2012 7:23 am

We have finally managed to block some "bad" crawlers/spiders and we decided to disable the cache
completely since our site is being constantly updated with forum, comments, hits, rating etc.

Maybe the best action we took and something that is I suggest to anyone is posting an xml sitemap to google that was hammering our site. Now everything's back to normal!


Thank for your valuable help!

Takis Tsogkarakis
ttsog
 
Posts: 4
Joined: Fri Jun 15, 2012 12:02 pm

Postby Geraint » Fri Oct 12, 2012 8:22 am

Glad to hear you sorted it out. Keep an eye on it since there are always new 'players' out there who are not always as well behaved as Google.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42781
Joined: Fri Feb 15, 2008 6:14 pm


Return to Jevents 2.x (Free Access)

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there are 0 users online :: 0 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: No registered users