Jevents 2.x (Free Access)

SOLVED - Add new Event page contain JS errors

Discuss JEvents 2.x for Joomla 1.5-2.5 here - club members can use the special club forum for faster response times.
Forum rules
When requesting support please follow these steps:

1. Update all JEvents add on's first, via the Joomla! Updater
2. Copy and Paste the JEvents Support Information from the JEvents Control Panel.
3. If you get a 500 error OR white page, enable Maximum Error Reporting in Joomla! Global Config and visit the page again, this should give you a more detailed error and help us provide a prompt response.

Postby MojoMateo » Fri Dec 16, 2011 10:58 pm

Hello,
i have a fresh installation of Jevent 2.0.11 and my Add event pge look like this:

Image

I can see a lot of Js error in the firebug console.

Some looks like mootools error, and it's totaly possible because i have manualy updated the mootools-core.js file because i need the lasts updates of moo.
MojoMateo
 
Posts: 20
Joined: Fri Dec 16, 2011 10:52 pm

Postby carcam » Sat Dec 17, 2011 12:10 am

Which Joomla! version are you using?

Can you please check using another editor? (for instance tinymce)
¿Sabías que tenemos soporte en español para los miembros del Club de JEvents? ¡ÚNETE AHORA!
User avatar
carcam
Team Staff
 
Posts: 7105
Joined: Wed Aug 06, 2008 7:50 pm
Location: Almería

Postby MojoMateo » Sat Dec 17, 2011 12:47 am

it's joomla 1.7

the difference between tiny or jck it that using tiny makes me able to save an event and not with jck but nothing else
MojoMateo
 
Posts: 20
Joined: Fri Dec 16, 2011 10:52 pm

Postby carcam » Sat Dec 17, 2011 10:20 am

Visual editors use a lot of javascript, so a good approach to identify this kind of errors is:

1. Disabling them (choosing no editor for instance)
2. cleaning your browser cache or even testing with another browser
3. Trying again

If the test with no browsers does work, start testing with tiny and after that with fck. Obviously cleaning the cache each time.

Can you please try this?

By the way, I am assuming you are in the backend of your Joomla! site, if you are using frontend the problem might be a conflict with any javascript function of your frontend (like for instance jQuery or one of your template libraries).
¿Sabías que tenemos soporte en español para los miembros del Club de JEvents? ¡ÚNETE AHORA!
User avatar
carcam
Team Staff
 
Posts: 7105
Joined: Wed Aug 06, 2008 7:50 pm
Location: Almería

Postby Geraint » Sat Dec 17, 2011 10:39 am

JEvents uses some special functions that Joomla has added to Mootools to allow 1.2.5 backwards compatability.

You may have removed these I suspect
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42799
Joined: Fri Feb 15, 2008 6:14 pm

Postby MojoMateo » Sat Dec 17, 2011 12:47 pm

i'm going to try your solution carcam,
but i suspect that geraint is wright i have downloaded latest version of mootoools from mootools.net i'm going to try something
MojoMateo
 
Posts: 20
Joined: Fri Dec 16, 2011 10:52 pm

Postby MojoMateo » Sat Dec 17, 2011 1:03 pm

it's ok i have replaced the /media/system/js folder from the original joomla installation folder and it works
MojoMateo
 
Posts: 20
Joined: Fri Dec 16, 2011 10:52 pm


Return to Jevents 2.x (Free Access)

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there is 1 user online :: 1 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: Bing [Bot]