Jevents 2.x (Free Access)

SOLVED - Time displayed incorrectly after upgrade

Discuss JEvents 2.x for Joomla 1.5-2.5 here - club members can use the special club forum for faster response times.
Forum rules
When requesting support please follow these steps:

1. Update all JEvents add on's first, via the Joomla! Updater
2. Copy and Paste the JEvents Support Information from the JEvents Control Panel.
3. If you get a 500 error OR white page, enable Maximum Error Reporting in Joomla! Global Config and visit the page again, this should give you a more detailed error and help us provide a prompt response.

Postby PTO » Thu Dec 08, 2011 3:19 pm

Hi Geraint

I've just upgraded jEvents from v1.5.5 to v2.0.11.

My meetings start at 7:30pm, but the time of each meeting is now displayed in the main calendar and tooltip as ":30". JEvents Latest shows it correctly as 7:30pm.

Any idea where my missing hour has gone please? :shock:.

Thanks,

Mike

Joomla v1.5.25
PHP v5.2.17
MySQL v5.1.59
Apache v2.2.3
PTO
Silver Members
 
Posts: 62
Joined: Thu Jul 16, 2009 7:46 am

Postby Geraint » Thu Dec 08, 2011 4:55 pm

What language are you using?

Also what time formatting settings did you set in JEvents
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42837
Joined: Fri Feb 15, 2008 6:14 pm

Postby PTO » Fri Dec 09, 2011 9:15 am

Language is UK English and the language override plugin is enabled.

Time format is 12hr.

I didn't make any changes to jEvents configuration after installing the upgrade.
PTO
Silver Members
 
Posts: 62
Joined: Thu Jul 16, 2009 7:46 am

Postby Geraint » Fri Dec 09, 2011 10:43 am

Sorry - I meant the date format? Are you on a windows server by any chance?
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42837
Joined: Fri Feb 15, 2008 6:14 pm

Postby PTO » Fri Dec 09, 2011 2:32 pm

Date format is the default - FromLanguage File.

This is my localhost test site, running on a Windws PC. I always test upgrades here before changing my live site.

Mike
PTO
Silver Members
 
Posts: 62
Joined: Thu Jul 16, 2009 7:46 am

Postby Geraint » Fri Dec 09, 2011 2:40 pm

check the values in the language file - I suspect you are using a strftime format that is not supported by windows. See http://www.jevents.net/en/jevents-15-to ... vents-154-
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42837
Joined: Fri Feb 15, 2008 6:14 pm

Postby PTO » Fri Dec 09, 2011 2:55 pm

You could be right, because if I change the date format to US then the time displays correctly.

I edited en-GB.com_jevents.ini and changed the Time Format from %l:%M%P to %#I:%M%p and now it's working correctly.

Thanks for the prompt support.

Mike
PTO
Silver Members
 
Posts: 62
Joined: Thu Jul 16, 2009 7:46 am


Return to Jevents 2.x (Free Access)

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there are 0 users online :: 0 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: No registered users