Jevents 2.x (Free Access)

SOLVED - Latest Events Module adding line breaks

Discuss JEvents 2.x for Joomla 1.5-2.5 here - club members can use the special club forum for faster response times.
Forum rules
When requesting support please follow these steps:

1. Update all JEvents add on's first, via the Joomla! Updater
2. Copy and Paste the JEvents Support Information from the JEvents Control Panel.
3. If you get a 500 error OR white page, enable Maximum Error Reporting in Joomla! Global Config and visit the page again, this should give you a more detailed error and help us provide a prompt response.

Postby groovmon » Sun Oct 09, 2011 8:52 am

I'm having trouble getting rid of a couple line breaks that are showing up between the module title and the mod_events_latest_table.
Image

When I turn off the option to display the module title, I still get these two mysterious line breaks.
Image

They are not in my html and other modules that I put in that position don't have the problem. Any ideas about what I might be doing wrong here. That extra space is pretty ugly on the frontend.

Thanks
groovmon
 
Posts: 3
Joined: Sun Oct 09, 2011 8:28 am

Postby Tonyp » Sun Oct 09, 2011 10:46 am

is there anything above that is not displayed?!
---------------------------------------
Feel free to PM me if you would like Custom Installs or Joomla! related work for a competitive quote.

User avatar
Tonyp
Team Staff
 
Posts: 23809
Joined: Tue Oct 12, 2010 9:12 pm
Location: Isle of Man

Postby groovmon » Sun Oct 09, 2011 7:24 pm

Hmmm... not sure I understand the question. Everything displays correctly. There's just a space between the module title and the table. If I put another module first in my sidebar, it displays fine. Then the lastest events module displays under, right where it should be, but with the same strange line breaks.

If I only put the lastest events module in the sidebar, same problem. I'm perplexed.
groovmon
 
Posts: 3
Joined: Sun Oct 09, 2011 8:28 am

Postby carcam » Mon Oct 10, 2011 7:04 am

Latest events module does not insert any <br> above the table, so I think it might be a glitch of your template.

Did you check the template overrides looking for modifications ad-hoc for latest_events module?
¿Sabías que tenemos soporte en español para los miembros del Club de JEvents? ¡ÚNETE AHORA!
User avatar
carcam
Team Staff
 
Posts: 7114
Joined: Wed Aug 06, 2008 7:50 pm
Location: Almería

Postby groovmon » Tue Oct 11, 2011 4:07 pm

Well I figured it out. I was causing the problem in my custom format string.

The problem string:
<td class="latestShowDate">${startDate(%b<br>%d)}</td>
<td class="latestShowTitle">${title}</td>

The problem here is the carriage return between the two <td> tags.

The working string:
<td class="latestShowDate">${startDate(%b<br>%d)}</td><td class="latestShowTitle">${title}</td>

This fixed it right up.
groovmon
 
Posts: 3
Joined: Sun Oct 09, 2011 8:28 am

Postby carcam » Wed Oct 12, 2011 6:20 am

Yes, that's true, the line breaks in the format strings are replaced by <br>. Thank you for sharing!
¿Sabías que tenemos soporte en español para los miembros del Club de JEvents? ¡ÚNETE AHORA!
User avatar
carcam
Team Staff
 
Posts: 7114
Joined: Wed Aug 06, 2008 7:50 pm
Location: Almería


Return to Jevents 2.x (Free Access)

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there are 2 users online :: 2 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: Bing [Bot], Yahoo [Bot]