JEvents 1.5 (No longer actively supported)

Search in template returning no events

JEvents 2.0 was launched over 2 years ago and the latest stable version is version 2.2 which will run on Joomla 1.5 and Joomla 2.5. JEvents 1.5 is therefore no longer actively supported - you should upgrade to JEvents 2.2+ as soon as possible.
Forum rules
Please include as much detail in any test or bug reports for JEvents 1.5 as possible.

First of all, check if you are running the latest available version of Joomla! and JEvents. Posts for issues, where both systems are not updated, will be ignored.

We need the following at least:

* PHP version (e.g. 5.2.5). Note: Support for PHP4 is discontinued.
* Joomla! version
* JEvents version
* Web Server software (Apache or IIS with version number if possible)
* Server Operating system (e.g. Linux, Windows, Solaris, Darwin ...)
* Database version
* memory_limit from your phpinfo
* Web browser and version

Please enable error reporting and include any error messages in your posting. You do this via the Joomla Configuration - set "error reporting" to "maximum" on the Server tab.

Finally, please describe the steps required to recreate the problem and also please enable error reporting and give us any error messages generated.

Postby jc513 » Sun Feb 08, 2009 6:13 pm

Using SVN 1297 of jEvents Alpha3. Using the Search option in the templates returns "No events for ...." when running the keyword search. Works fine on an alpha2 site I have. Results from J! search option working. Anyone else experiencing?
jc513
 
Posts: 46
Joined: Sun Nov 16, 2008 4:20 pm

Postby Geraint » Sun Feb 08, 2009 7:11 pm

Please test beta
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42781
Joined: Fri Feb 15, 2008 6:14 pm

Postby jes39 » Sun Feb 08, 2009 11:08 pm

Search option not finding events - I have the same situation
* PHP version (e.g. 5.2.
* Joomla! version 1.5.9
* JEvents version beta 1296
* Web Server software (Apache
* Server Operating system (e.g. Linux
* Database version mysql 5

I got the following errors:
Warning: array_merge() [function.array-merge]: Argument #2 is not an array in ...components/com_jevents/libraries/dbmodel.php on line 1256

Warning: usort() [function.usort]: The argument should be an array in ...components/com_jevents/libraries/dbmodel.php on line 1257
jes39
 
Posts: 3
Joined: Sun Feb 08, 2009 11:02 pm

Postby jc513 » Mon Feb 09, 2009 1:35 am

Geraint, I am confused by your statement. I am running the latest SVN (just updated to 1299) and I have installed the search plugin from SVN 1287. Is this the beta you are referring. I have no problem returning search results for the J! search modules for calendar entries but the search option from within the templates produces "Search Results for Keyword: No events for....." even though the events are there. I even copy/pasted the exact title and content wording with no luck.

I have an older Alpha2 site where the search function from within the template works fine.
jc513
 
Posts: 46
Joined: Sun Nov 16, 2008 4:20 pm

Postby Geraint » Mon Feb 09, 2009 7:59 am

Thank jes39 the error message helped me find the problem - there was a missing " AND " in a query.

Please insert the line
Code: Select all
$query .= " AND ";


Just before
Code: Select all
$query .= ( $useRegX ) ? "(det.summary RLIKE '$keyword' OR det.description RLIKE '$keyword')\n" :


at line c. 1241 of components/com_jevents/libraries/dbmodel.php

Geraint
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42781
Joined: Fri Feb 15, 2008 6:14 pm

Postby jc513 » Mon Feb 09, 2009 1:53 pm

Yeap. That worked. Thanks. :D
jc513
 
Posts: 46
Joined: Sun Nov 16, 2008 4:20 pm


Return to JEvents 1.5 (No longer actively supported)

cron
  • Who is online
  • View new posts
  • View unanswered posts
  • In total there are 2 users online :: 2 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: Google [Bot], Yahoo [Bot]