JEvents 1.4

Disable caching of com_event

Postby jonathanq » Fri Nov 28, 2008 7:49 pm

Is there any way to disable the caching of the JEvents component?

com_event consistently fills up the server's disk space allotment. If I leave the site for a few weeks without checking the cache size it is normal to come back and find the com_event component using up 700 or 800 mb of space.

I don't mind taking a performance hit on having to go to the DB to show Event details instead of having it cached (while still having other parts of the site cached). It sure beats having to continually monitor the site's disk space usage and clear the cache when it gets too full.

Is that possible at all in JEvents or Joomla?

Any help would be appreciated - thanks!
jonathanq
 
Posts: 1
Joined: Wed Apr 09, 2008 9:52 pm

Postby AlanHumphrey » Tue Dec 30, 2008 7:30 pm

It sounds like there's a problem with your cache. If the cache is full it should delete entries (the oldest, presumably) until there's room for the new entry.

What are your Cache Settings? (Under Global Configuration - System)
AlanHumphrey
 
Posts: 161
Joined: Sat Dec 27, 2008 7:19 pm

Postby inthysite » Thu Jan 01, 2009 5:55 pm

I have this same problem. I went to clear out my cache and Joomla timed out. When I went to the cache directory with my ftp program there were over 12,000 cache files from Jevents. I had to manually delete them.

This is curious because I only have at most 12 scheduled events, about 4 of which are recurring.

My cache settings in global config are fine as this does not happen with other components or with the content cache. Those all get deleted at the proper time. It is only Jevents that has this problem.
inthysite
 
Posts: 7
Joined: Tue Aug 26, 2008 11:35 pm

Postby AlanHumphrey » Fri Jan 09, 2009 1:54 am

I wonder if you get a separate cache for each session...

Anyway you could try clearing the cache every time by inserting these lines above the switch statement in events.php (approx line 2367)

Code: Select all
mosCache::cleanCache('com_events');
mosCache::cleanCache('com_content');
AlanHumphrey
 
Posts: 161
Joined: Sat Dec 27, 2008 7:19 pm

Postby inthysite » Thu Jan 15, 2009 4:14 pm

I tried adding the above code and then went in to view the calendar but the cache files were still there so I don't think this works.

This is a serious problem. Every week I update my church's website and every week the cache files total in the tens of thousands. This dramatically affects system performance as this number grows. And seeing how I display upcoming events on the frontpage it dramatically affects the page load time.

There must be some solution to this.
inthysite
 
Posts: 7
Joined: Tue Aug 26, 2008 11:35 pm

Postby AlanHumphrey » Fri Jan 16, 2009 2:58 am

just tried it myself and it works. the thing is it doesn't work instantly (don't know why). But after navigating around my events, looking at different views (monthly, daily, event) the cache directory eventually cleaned itself out. Commenting out the lines (to turn off cache cleanup) brought back the cache items, uncommenting them caused the cached to clean itself up eventually.

Give it a whirl and see if your experience is different.
AlanHumphrey
 
Posts: 161
Joined: Sat Dec 27, 2008 7:19 pm

Postby inthysite » Mon Feb 02, 2009 12:55 pm

Thank you AlanHumphrey, I implemented this again last week and did not see any immediate results but when I went back this week to make my updates I noticed that there were only two cache files for events. I don't understand why it doesn't take effect right away but as long as it takes care of the problem I'm cool.

So again, thank you for your help.
Allen
inthysite
 
Posts: 7
Joined: Tue Aug 26, 2008 11:35 pm


Return to JEvents 1.4

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there are 0 users online :: 0 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: No registered users