Jevents 1.4 for Joomla 1.0.x

Blank gif obscuring icons!

Postby shargraves » Fri Jul 03, 2009 2:02 pm

Hi all,

First post - and I'm baffled here!

The transp.gif that is used for the Icon Nav bar above the events calendar is not appearing transparent!

I'm using firefox 3.0.11 - and I have looked at it in IE too - (sad I know)

I am just baffled - I even created my own blank gif and uploaded that to overwrite the one installed just on the off chance.....

HELP!

The page using it is http://www.hope.ac.uk/index.php?option= ... temid=2379

Can people see the icons? Or are they half obscured.... It's frida, it's hot in the office and my brain is leaking out my ears I've been stuck on this for so long!

Any suggestions would be hugely appreciated!
shargraves
 
Posts: 2
Joined: Fri Jul 03, 2009 1:55 pm

Postby Geraint » Fri Jul 03, 2009 3:20 pm

Can I recommend you use the firebug addon for Firefox. It took me 30 seconds to find the problem template_css.css line c. 421 - the image background colour!!
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42795
Joined: Fri Feb 15, 2008 6:14 pm

Postby shargraves » Fri Jul 03, 2009 4:52 pm

awesome - my first go at this sort of thing - so I hold my hands up!

Will also get that plugin you recommend -
shargraves
 
Posts: 2
Joined: Fri Jul 03, 2009 1:55 pm

Postby bgoldnyxnet » Thu Aug 20, 2009 6:52 pm

I am also seeing this problem. I'm using the "trueblue" template.

My calendar is at http://www.lasfsinc.info///index.php?op ... Itemid=185
bgoldnyxnet
 
Posts: 3
Joined: Thu Aug 20, 2009 6:29 pm

Postby bgoldnyxnet » Wed Sep 02, 2009 9:01 pm

Geraint wrote:Can I recommend you use the firebug addon for Firefox. It took me 30 seconds to find the problem template_css.css line c. 421 - the image background colour!!


template_css.css varies with which template you are using (and sometimes even which version of Joomla). Instead of giving a fixed line number, can you provide a context diff? Or specify the selector and the property name and value to change?

That would help me apply the change to my site, which uses a different template.
bgoldnyxnet
 
Posts: 3
Joined: Thu Aug 20, 2009 6:29 pm

Postby bgoldnyxnet » Mon Oct 19, 2009 2:42 am

Geraint wrote:Can I recommend you use the firebug addon for Firefox. It took me 30 seconds to find the problem template_css.css line c. 421 - the image background colour!!


There was no response to my request for more info, so I did a little digging around. I'm no CSS expert, but I did manage to find the problem.

To start with, the problem isn't in template_css.css. It's in components/com_events/events_css.css

I added the following property:
background-color: transparent;
to the selectors under the comment "Iconic Calendar Navigation". The selectors are:
td.iconic_td
div.nav_bar_cal
tr.icon_labels
div#ev_icon_yearly
div#ev_icon_weekly
div#ev_icon_daily
div#ev_icon_search
div#ev_icon_jumpto

It may be that some of these are redundant. Somebody else can try to find the minimal set required to make this work. All I care about is that my calendar now displays correctly. You can see it at:
http://www.lasfsinc.info///index.php?op ... Itemid=185
bgoldnyxnet
 
Posts: 3
Joined: Thu Aug 20, 2009 6:29 pm


Return to Jevents 1.4 for Joomla 1.0.x

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there are 0 users online :: 0 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: No registered users